This is really just a placeholder post for now as I am starting to receive emails and forum posts asking about Firefox 1.5 Beta compatibility for the User Agent Switcher and Web Developer extensions.

Update: The User Agent Switcher and Web Developer extensions are both now compatible with Firefox 1.5 Beta.

My usual stand is that I do not support nightly, alpha or beta builds for either extension—as noted in the User Agent Switcher and Web Developer FAQs. This is because too many little bugs appear in these builds that can affect the behavior of an extension and I just do not have the time to debug an issue to work out if it is a problem with that build or my extension.

However, with Firefox 1.5 Beta offering significant improvements over Firefox 1.0 I suspect that many people will be trying it out—myself included. Therefore I am planning on making both the User Agent Switcher and Web Developer extensions compatible with Firefox 1.5 Beta, with the caveat that I will not be providing any support for issues that are only related to Firefox 1.5 Beta and do not occur in Firefox 1.0.

Changes Required

Making the User Agent Switcher extension compatible should be straightforward enough and I hope to release version 0.6.7 this weekend. This will not include any new functionality, but will merely add Firefox 1.5 Beta and Netscape support along with some minor code optimization.

Unfortunately, the Web Developer extension is a little more tricky. I have spent the last few months working on the next release of the extension and version 0.9.3 is effectively frozen. If version 0.9.3 can be made compatible with Firefox 1.5 Beta by just updating the supported version then I will do that this weekend. Otherwise people will have to wait for the beta of the next release for a version of the Web Developer extension that is compatible with Firefox 1.5 Beta, which should not be too far away if everything goes according to plan.

So please stay tuned—I will be updating this post with the latest information as I work on making the User Agent Switcher and Web Developer extensions compatible with Firefox 1.5 Beta.