With the last release of the User Agent Switcher extension I increased the maximum supported version for Firefox to 0.10+ so that it works on Firefox preview release builds.

I am currently working on the next release of the Web Developer extension, but it is not yet ready for release. Therefore I have just updated version 0.8 with the same maximum supported version for Firefox as that of the User Agent Switcher extension. The updated Web Developer extension is available from the download page and should be on Mozilla Update soon.

I have also updated the Web Developer to-do page to list what I have already coded for the next release so that you can see the progress that I am making.